Bem-Vindo, Visitante
Nome de usuário: Senha:

TÓPICO: (Resolvido) Problema na Viewport

(Resolvido) Problema na Viewport 18 Mar 2016 16:49 #149587

  • gasperalemao
  • Avatar de gasperalemao
  • Offline
  • Wireframe
  • Postagens: 3
  • Karma: 0
Olá pessoal. Estou com um problema na Viewport do Blender.

Deem uma olhada:



Parece que há 2 planos sobrepostos, mas não é isso. Já verifiquei e este problema acontece com qualquer objeto q está muito longe da câmera ou com escala grande (maior que 40 metros).


Este aqui é apenas um cubo básico redimensionado (com escala já aplicada), mas que já apresenta problemas:

(Parece que é uma borda, mas é o erro)


Se eu ligo o Ambient Occlusion também acontece este erro:




Minha cena está em Metric, com 0.01 de escala.
Meu Viewport clip está: Start 1mm / End 1km.

Alguém tem alguma idéia do que pode estar acontecendo aqui???
Seria alguma coisa relacionada à escala da cena que eu também preciso ajustar?

A viewport com esse problema me impossibilita usar cenas muito grandes que eu preciso fazer aqui.
Já agradeço qualquer ajuda!!
Última Edição: 21 Mar 2016 11:34 por gasperalemao.
O administrador desabilitou o acesso público de escrita.

Problema na Viewport (aparentemente simples) 18 Mar 2016 18:31 #149591

  • jeacom256
  • Avatar de jeacom256
  • Offline
  • Rendered
  • Cadeiras são uteis !!
  • Postagens: 397
  • Obrigados Recebidos: 52
  • Karma: 9
pelo que percebi, ha paredes com duas faces, a viewport renderisa as faces baseandose em um bufer de valores da profundidade de cada face, se as faces ficam muto distantes da câmera mas próximas entre si, o buffer de profundidade Z pode não ter números precisos o suficiente para saber qual parte está na frente e esse erro acontece,

o famoso Z-Fight.

infelizmente, não conheço um jeito de resolver esse problema, sempre.

mas para objetos sólidos ha um jeito:

no painel properties da 3D view ("atalho N")
dentro de Shading marque backface culling isso ocultara as faces que não apontam pra câmera.
o caos não passa de mais um tipo de padrão.

Cadeiras São úteis!
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: gasperalemao

Problema na Viewport (aparentemente simples) 18 Mar 2016 18:56 #149598

  • mvaranda
  • Avatar de mvaranda
  • Offline
  • Rendered
  • Postagens: 474
  • Obrigados Recebidos: 87
  • Karma: 46
Talvez se voce trabalhar numa escala menor ajude (/10, /100 ou ate /1000).
A 3DView Camera tem o Clipping no Painel N. Mas acho que nao ajuda mexer nos valores maximo/minimo neste caso.
Junte-se a nós e aprenda mais sobre CG:
www.cglabs.com.br
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: gasperalemao

Problema na Viewport (aparentemente simples) 19 Mar 2016 15:21 #149609

  • gasperalemao
  • Avatar de gasperalemao
  • Offline
  • Wireframe
  • Postagens: 3
  • Karma: 0
Muito obrigado jeacom256 e mvaranda!

As duas dicas funcionaram muito bem. No caso eu marquei backface culling e coloquei o Clip Start: 5cm
e os problemas acabaram!


Agora eu posso continuar meu projeto :laugh::laugh::laugh:
O administrador desabilitou o acesso público de escrita.

Problema na Viewport (aparentemente simples) 20 Mar 2016 19:20 #149611

  • jeacom256
  • Avatar de jeacom256
  • Offline
  • Rendered
  • Cadeiras são uteis !!
  • Postagens: 397
  • Obrigados Recebidos: 52
  • Karma: 9
aproposito, bela planta.
o caos não passa de mais um tipo de padrão.

Cadeiras São úteis!
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: gasperalemao

Problema na Viewport (aparentemente simples) 21 Mar 2016 11:39 #149612

  • gasperalemao
  • Avatar de gasperalemao
  • Offline
  • Wireframe
  • Postagens: 3
  • Karma: 0
Vlw. Estou fazendo testes modulares para usar no Unity e ver qual é o melhor workflow para fazer alguns projetos aqui.
Quando eu terminar um projeto eu posto aqui no fórum.

O administrador desabilitou o acesso público de escrita.
Tempo para a criação da página:0.076 segundos